FishingTN.com Tennessee's Fishing and Boating Community

Go Back   FishingTN.com Tennessee's Fishing and Boating Community > General Discussion > Fishing Gear
Register FAQ Members List Calendar Mark Forums Read
Google
 


Reply
 
Thread Tools
  #1  
Old 08-26-2019, 09:08 AM
spottedbass's Avatar
spottedbass spottedbass is offline
Senior Member
 
Join Date: Jun 2005
Location: Hendersonville
Posts: 478
Default Xi5 Issues

Well I went out Saturday and my Xi5 does not find a satellite signal. When I hit the anchor button all I get is one beep. The satellite indicator light is not coming on either. Anyone have any idea what might be going on?
Reply With Quote
  #2  
Old 08-28-2019, 05:09 PM
Buccaneer Buccaneer is offline
Senior Member
 
Join Date: May 2007
Location: Hendersonville
Posts: 635
Default

Call Motorguide, you need a software/firmware update. Google it, lots of info.
Reply With Quote
  #3  
Old 09-01-2019, 04:11 PM
spottedbass's Avatar
spottedbass spottedbass is offline
Senior Member
 
Join Date: Jun 2005
Location: Hendersonville
Posts: 478
Default

Well Mercury sent me the software update. I applied the update in my driveway on Thursday. After the update my Xi5 was finding the GPS signal again. I take the boat to the lake on Saturday and the stupid thing doesn't get a signal anymore. It won't get a signal in my driveway either in the same place it got one on Thursday. Good thing it is still under warranty Another call to Mercury on Tuesday.
Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:30 AM.


Site best viewed at 1280X1024
FishingTN.com